Update to CMake, tweaks & dds
[convexer.git] / cxr / CMakeLists.txt
diff --git a/cxr/CMakeLists.txt b/cxr/CMakeLists.txt
new file mode 100644 (file)
index 0000000..eb0455f
--- /dev/null
@@ -0,0 +1,19 @@
+project( cxr )
+
+add_library( ${PROJECT_NAME} SHARED
+   cxr.c
+   cxr.h
+   cxr_math.h
+   cxr_mem.h
+)
+
+target_compile_definitions( ${PROJECT_NAME}
+   PRIVATE CXR_SO CXR_DEBUG CXR_VALVE_MAP_FILE
+)
+
+target_compile_options( ${PROJECT_NAME}
+   PRIVATE -Wall -Wno-unused-variable -Wno-unused-function
+   -std=c99 -pedantic
+)
+
+target_link_libraries( ${PROJECT_NAME} m )